Getting Error in cadCAD Tutorials

I recently started cadCAD tutorials. When I run Part 1, I am getting a type error as below.

cadCAD Version: 0.4.28
Execution Mode: single_proc
Simulation Dimensions:
Entire Simulation: (Models, Unique Timesteps, Params, Total Runs, Sub-States) = (0, 0, 0, 0, 0)
Traceback (most recent call last):

  • File “”, line 1, in *

  • run.execute()*

  • File "**/python3.7/site-packages/cadCAD/engine/", line 149, in execute

  • self.exec_context, self.exec_method = auto_mode_switcher(config_amt)*

TypeError: cannot unpack non-iterable NoneType object

Is there a solution to rectify it?

I’m getting a similar issue. Can anyone help please?


This fixed it.

Hey @drivepilot @ChaosC were you guys able to solve it? Getting same error here…
Don’t know how the github link is helpful.

@bernardovic I just got it running after running into the same issue…

Check out the lines that I commented and it should work… I think the configs needed a prefix so if you add the exp. prefix to the configs and then update the experiment name variable it should run.

limit on images I can upload but this should be the other place you need to change